ManyChat

Issues with Flows and How to Resolve Them

There's a number of issues you may come across while setting up your Flows - but don't worry, just read through this article to find a quick solution to your problem :)

Table on contents:

1. Can’t publish a flow

2. Can’t preview a flow

3. Flow wasn’t sent to a subscriber

4. ‘manychat.com’ appears in messages

5. Post from my Fan Page was sent to all Subscribers



1. Can’t publish a flow

First, you need to check if there are any unattached steps or empty blocks in your flow. Open this flow in 'Flow Builder', and then click 'Publish' - the problematic block will be highlighted in red by the system. Make sure to delete all empty blocks and unattached steps. Along with that, you can see the cause of the issue in the red frame like on the screenshot below:


If your page is on a Free account, make sure that you don't have any Pro features in this flow. While you're on a Free plan, you can add Pro features to flows, but you won't be able to Publish them eventually. You can either remove the block with Pro features or Upgrade this page to Pro to resolve this situation.



2. Can’t preview a flow

To receive Previews of a certain flow you need to Opt-In to your bot first. To do that, head to 'Settings' => 'Notifications' in your ManyChat account and click 'Subscribe' button in the 'Messenger Notifications' section in order to Opt-In to your bot and receive bot notifications/preview flows.



3. Flow wasn’t sent to a subscriber

There are a few reasons why a flow may not be sent to your bot's subscribers as it can be used in any automation with its own configurations. First of all, make sure the flow in question is Published, doesn’t contain empty cells (action blocks, user input fields, sequences, etc) and is not permanently deleted.

If a flow is used as your Welcome Message and it’s not sent after clicking “Get Started” button (although it’s Enabled in your account), try refreshing permissions - you can do it by clicking “Refresh Permissions” button in Settings => General.

If your Default Reply is not sent, check if it’s Enabled and how often it’s set to fire. If everything's set up properly and the Default Reply is still not triggered, refreshing permissions may also help. 

Main Menu doesn’t react to clicks? Probably, it’s a permissions issue, too. Try refreshing them before anything else!

A flow that’s attached to a Keyword will not be sent if the keyword is Disabled. And of course, don’t forget about the magic “Refresh Permissions” button! 

You’re subscribing yourself to a Sequence and its message is not arriving? Make sure it’s Activated and you haven’t been subscribed to the sequence before - if you've tested this sequence, you're already subscribed to it and won't receive its messages again. Just try unsubscribing yourself from the sequence and subscribing back to it - this should restart the sequence for you.

If you’ve set up a Growth Tool and your subscribers don’t receive its opt-in flow, check if the GT is active and make sure it’s set up correctly - you can check out the guides for each GT in the Help Center.

If neither of these troubleshooting steps helps you, don't hesitate to contact our friendly support at any time!


4. 'manychat.com’ appears in messages:

Sometimes you can see 'manychat.com' at the bottom of your Card or a List item - this is how it looks like:

First of all, please note it's not a branding message that is being shown by the system. The reason you see this is that your Card URLs are changed by Card URL Shortener. This has to be done as it's technically impossible to provide you with Click-Through Rate data without converting your link into the ManyChat link as all the data goes through ManyChat servers. You can disable this feature - just head to Settings => General => Card URL Shortener and choose "shortener is disabled (No CTR!)” option:

If you don't want your links to be displayed as 'manychat.com', you can change it to 'mnch.at' and still have the CTR data. 


5. Post from my Fan Page was sent to all Subscribers

If you post something on your FB Fan Page and this post gets sent to your subscribers privately in Messenger right away - it is a sign that you've enabled a Facebook Account autoposting channel. To disable it, head to 'Broadcasting' tab in your ManyChat account, click 'Autoposting', then click on the channel you wish to disable and change its status to 'Disabled' in the drop menu.

 

Don't forget to click green 'Save' button below to save changes.

If you're still experiencing any issues after following all of the steps listed here - please feel free to contact our Support Team at any moment! :)